Avoid duplication in Maven dependencies

Description

ap-openspaces 15.0 declares Maven dependencies on the following two libraries:

org.springframework:spring-aop:5.1.11.RELEASE
org.aopalliance:com.springsource.org.aopalliance:1.0.0

The former library is a superset of the latter, Having both libraries in the classpath is slightly dangerous: you have no guarantee that they contain the same class in classpath may cause pretty weird errors.

Please ensure that no duplicate classes are present in libraries you define as your Maven dependencies. There are free Maven plug-ins which may help you to identify if

Acceptance Test

Verified manually

Assignee

Niv Ingberg

Reporter

Ester Atzmon

Labels

None

Priority

Medium

SalesForce Case ID

12833

Fix versions

Commitment Version/s

None

Due date

None

Product

None

Edition

Open Source

Platform

All
Configure